게시물보기 #1,229

질문 미니톡 설치가 안되요 MCRYPT Module

0

인스톨을 할려니 MCRYPT Module 확인필요라고 나오는데

다른건 전부 확인됨이고 PHP MCRYPT Module 이 확인 필요로 나옵니다

카페24 웹호스팅을 이용중입니다.

어떻게 해야하나요?

Arisae
Arisae
LV.1 20/100
2019-08-06 15:24:42
답변 1
0

혹시 사용하고 있는 호스팅의 PHP 버전이 어떻게 되시나요?

만약 PHP 7.2 버전 이상이라면 해당 모듈이 지원되지 않습니다.


그럴경우 미니톡 클라이언트 폴더의 class/default.func.php 파일을 열어 제일 위에 있는 함수 2개를 수정하여야 합니다.


아래와 같이 2개의 함수를 수정하신뒤


function MiniTalkEncoder($value,$key='') {
    $key = $key ? $key : $_ENV['key'];
    $padSize = 16 - (strlen($value) % 16);
    $value = $value.str_repeat(chr($padSize),$padSize);
    $output = openssl_encrypt($value,'AES-256-CBC',$key,OPENSSL_RAW_DATA | OPENSSL_ZERO_PADDING,str_repeat(chr(0),16));
    return base64_encode($output);
}

function MiniTalkDecoder($value,$key='') {
    $key = $key ? $key : $_ENV['key'];
    $value = base64_decode($value);
    $output = openssl_decrypt($value,'AES-256-CBC',$key,OPENSSL_RAW_DATA | OPENSSL_ZERO_PADDING,str_repeat(chr(0),16));
    $valueLen = strlen($output);
    if ($valueLen % 16 > 0) $output = '';

    $padSize = ord($output{$valueLen - 1});
    if (($padSize < 1) || ($padSize > 16)) $output = '';

    for ($i=0;$i<$padSize;$i++) {
        if (ord($output{$valueLen - $i - 1}) != $padSize) $output = '';
    }
   
    return substr($output,0,$valueLen-$padSize);
}


install.php 파일에 6번째 줄을

$checking_mcrypt = true;

으로 수정하신 후 시도해보시기 바랍니다.

알쯔
알쯔
LV.50 111,693/111,693
2019-08-17 18:09:21
답변이 이해가 잘 안되거나 추가적인 내용이 있다면
이곳을 통해 답변자와 질문자간에 댓글을 남길 수 있습니다.
답변 작성하기
답변을 입력하려면 먼저 로그인을 하여야 합니다.
목록 질문하기